Sunday, 3 December 2017

My Amiga Blog is back in business!

Hi All,

I am pleased to say that my study is finished for the year and exams done too as of today! This of course means that I can now return to my blog again!

It's good to be back.

It has not been an easy time for me since I stopped the blogs back in July. My father in law passed away suddenly in Japan in mid August which meant stopping everything to go to Japan to arrange and attend the funeral. It has been tough for my wife to deal with, being so far away from Japan and not being able to say goodbye.

In addition I have been quite unwell over the past few months, culminating in an emergency ambulance to hospital last month and a not so fun visit to the emergency room and lots of tests and pain pills. Fortunately things are on the improve and I feel considerably better now.

I have been studying when I have not been working, juggling that with my Adelaide Retro Computing Group responsibilities, continuing to help organise and run the monthly meetings.

Unfortunately it seems that the December 2017 Adelaide Retro Computing Group meeting may well be the last one. :-(

The other two organisers have decided to stop being involved from the end of this year, which leaves just me to carry on the groups activities. Given my health issues and lack of free time to take on running it by myself, I was left with no choice but to close the group down with the last meeting coming up this Friday December 8th. Hopefully we can see some of you there! I never say never of  course, and if someone is able to commit to help running the events for at least 12 months then maybe we can find a way to continue in 2018. We'll see how that pans out.

Just because I have been busy (and off air) does not mean I have been idle on all things Amiga. Far from it.

Those who follow my Facebook, Twitter and Instagram accounts will know I have continued to muck around with my Amigas still during this period when time allowed. I also mucked around a bit with my new FM Towns system too, but that is not really relevant to this blog so...

There have been some great Amiga demos released this past few months on the Classic Amiga, both AGA and OCS/ECS demos!

I have also continued my AmigaOS 4.1 Final Edition beta testing duties on the new AmigaOne A1222, but unfortunately can't discuss that since that work is covered under NDA.

I recently wanted to get the Vampire 500 V2 into my Amiga 500, but that meant fixing the Amiga 500, which has not worked since the last time I tried to use the Vampire in it...heh.

While mucking around with troubleshooting that, I reseated all the chips, and unfortunately managed to break some of the pins on the fat agnus chip when removing it! Argh! So the A500 went into storage until I could source another one.

Finally though I managed to get another one from Germany recently, so I pulled apart the A500 again to hopefully get it working:

My Amiga 500 has an Indivision ECS installed, as well as a gotek mounted on a 3D printed floppy chassis that is designed to fit the A500 case without any modifications:

Here is the missing Fat Agnus chip location:

Here it is with the new Fat Agnus chip installed:

Unfortunately though, the system still doesn't boot and work as expected. Green screens, red screens and black screens, with no idea what the issue is yet... I tried changing the CPU, the kickstart roms and even installed the Vampire 500 V2 again minus the cpu and kickstart roms but no joy as yet. Sigh, back into storage for now until I can come up with another way to fix it or replace the motherboard. Looking like that path is more likely...

So I hooked up the Amiga 600 to make sure it was still working and put it all back together as a complete system again. Here it is working great:

Back in August 2017 at the Adelaide Retro Computing Group meeting, some friends and I organised a two player null modem link up between my Amiga 2000HD and a friend's Amiga 4000D. It made for a lot of fun that night, although being beaten so badly at link up two player Stunt Car Racer made me feel very embarrassed - I thought I was good at that game! At least I won at Lotus 2 and Vroom :-)

As you may recall my Amiga 2000HD was downgraded from the Vampire installation that was in it before, and now has a 68030 accelerator and 68882 FPU, 128MB fast memory, Picasso II RTG AmigaOS 3.9 BB2 Workbench, Rapid Road USB installed on X-Surf 100 network card, Prisma Megamix card, MegAChip (2MB CHIP), Oktagon SCSI card with 1GB HD (need to upgrade that still), SCSI CDROM, Indivision ECS and kickstart switcher 1.3/2.0/3.1. Whew. :-)

The Amiga 4000D here next to my A2000HD is not mine, but does have the new MNT VA2000 RTG Zorro graphics card installed, 060 and plenty of other goodies too:

Let's take a closer look at the MNT zorro RTG graphics card, with scan doubled pass through native Amiga display addon with HDMI output:

Meanwhile, reviewing on things that happened since the blog stopped, back in July 2017 I replaced the CDTV SCSI card module I bought a long time ago now (and had plenty of issues with it too) with a new one I found on Ebay. This one works a lot better and much more consistent - the old one is on the left, the new one on the right:

The new one is a lot simpler on board as you can see:

It still has the internal SCSI cable, as well as the external SCSI connector, and a SCSI card disable switch.

I hooked up my old Amiga 2000HD 52MB SCSI hard disk to it and it worked perfectly - here playing some mods using Octamed Professional v3 on the hard disk:

Of course I soon got distracted, playing Psygnosis demo CD, and some music too - the CDTV is so great for CD playback:

I also tried out my Defender of the Crown Extended Collector Edition CDTV version (not pictured).

I got into playing Xenon 2 Megablast, the CDTV version. The audio is fantastic on this compared to the original Amiga version. As a big fan of Bomb the Bass, I was glad to finally here the remixed versions of their Megablast (Hip Hop On Precinct 13) included on the CDTV version:

I received a spare Amiga 4000D from a friend in Sydney that has been tower converted (not working) with a number of interesting expansions, including the rare Picasso IV Paloma add on! :-)

This A4000D has been towerised in a Dell Inspiron desktop case from the late 1990's with plenty of modifications.

Cyberstorm 060 accelerator with 128MB memory and the optional SCSI addon installed, connected to the SCSI Hard disk and SCSI CDROM:

Also installed is a USB v1 zorro card I haven't seen before, with the Picasso IV Paloma and PVE 2.0 expansion installed:

Once the daughterboard and cards are removed (difficult job given they were mounted into a customised cage, you can see the Amiga 4000D motherboard, 16MB memory, along with a Varta battery installed. Argh! Get that off quick! (Yes, I did...)

You can see the mouse/joystick extension cables to route the A4000D ports on the motherboard to new locations on the rear of the case, since they would otherwise be completely inaccessible.

Unfortunately although this system looks impressive and powers on, there is nothing appearing on the screen and does not boot. I have stripped it of all non-essential boards and still nothing. I have tried a known working cyberstorm 060 and even the original Commodore 040 accelerator board from my own A4000D but no go...guess this one also goes into the too hard basket for now.

Just to prove that not everything Amiga related is Classic Amigas, I also installed the updated Enhancer v1.3 software package from A-EON Technology on my AmigaOne X1000.

I enjoyed greatly the updated PTP functionality in Enhancer on AmigaOS 4.1 Final Edition Update 1, which allows me to transfer my photos and videos from my iPhone 7 to my X1000!

I have to say this is a really big step forward on AmigaOS 4.1 final Edition Update 1, thanks to Enhancer - it works great:

Here it is showing previews of the photos on my iPhone, allowing me to select the photos for transferring to my X1000:

Here is the transfer underway. And yes, I do have a lot of photos on my iPhone!

 I also played around with the new updated Radeon HD and Warp3D Nova drivers, enjoying the live workbench cube demonstration, which has a rotating cube with each face containing a live view of my Workbench screen. As I move the mouse and windows around, it updates on the cube in real time. Very cool:

Last but not least, I also played around with the updated E-UAE with SDL RTG support, which allows me to get full screen 1920x1080 emulated Workbench OS3.9 on my X1000:

Here is the lines highlighted in the E-UAE configuration file .uaerc I had to modify to get the RTG card support, which I could then setup through Picasso 96 under the emulated OS3.9 installation on the X1000:

Here is the resulting 1080p AmigaOS3.9 emulated Workbench screen on my X1000. I could switch easily between it and the normal AmigaOS 4.1 Final Edition Update 1 screen with the Amiga-M/N keyboard combination.

Well that should bring up mostly up to speed with what I have been up to during my time away. I did installed a replacement RapidRoad USB into the X-Surf 100 on my Amiga4000D system too, and finished the reinstall of the Amiga 1200 system hard disk, which I have been enjoying many 030 AGA demos as I have been typing this entry tonight!

Oh, and I recently tweaked the appearance of this Amiga blog, using a new theme Blogger has available now that looks much more modern. Still finding my way around it (having some trouble with the image on the left which doesn't auto size right for some reason) and expect to tweak it some more still. Happy to receive feedback on what works well and what doesn't.

I will hopefully do a few more blog entries before the Xmas break. Stay tuned!


  1. Hey Epsilon. Seeing my Amiga 4000 on display for the world renewed my efforts to get the native screen to stop moving to the top left corner of the screen, and after a marathon 6 hour stint, i found the issue and got it fixed, in fact it even fills the screen which is a nice bonus. Have also added two USB ports to the front panel, one on either side of the CF card/Floppy Mod - no damage done to the Amiga that way and they are sized just about right :). The firmware has also been fixed to stop the pixel junk you saw during bootup, and all other Zorro cards play nice as well so BigRamPlus and Ethernet are again in my machine. The 4000 is perfectly where i want it :) oh ok, 80Mhz would be nice.

  2. Epsilon, good to hear you're back! Really missed your blog.
    Not so good to hear about your health issues. Get well soon, you hear!!
    (on a side note, where are getting those fabulous desktop wallpapers?)

    1. Just do a Google Image search for "Anime Girls HD wallpaper" and you'll find them and plenty more too! :-)