Saturday, 30 August 2014

Tales of Gorluth on Amiga 600

Today I wanted to take a look at the recently released Classic Amiga game Tales of Gorluth on my Amiga 600.

The game was written by Amiworx Software, available in German and English language versions on the CD.  You can buy it for GBP11.80 from AmigaKit here.

I promptly received my game in the mail from AmigaKit - The CD itself and packaging looks very nice:

Back of the CD cover:

Inside CD case - so nice to have nice professional presentation:

CD insert cover also has the installation process and controls outlined:

The installation process is not very straightforward, and does not follow the instructions included in the cd insert above.  I found I had to muck around with it a bit to get it working.

In my case, I found I needed to first (as per the instructions) copy across the TOG_E folder from the CD to your Hard disk as described (see below for the CD contents):

Having done this you end up with this folder on your hard disk:

You then need to rename the TOG_E folder on your hard disk as TOG-E, and then extract the tog_e.lha file included on the CD over the top of this hard disk folder to get all the files.

You then get the talesofgorluth script that can be executed from a Shell. Note that this program does not work from Workbench, and needs you to boot with no startup-sequence, cd to the folder, and then run execute talesofgorluth to run it.

There is also known issues apparently running it under AmigaOS3.5 or AmigaOS3.9, although I have not tested this, as my Amiga 600 is running AmigaOS3.1.

Seriously - the installation process and instructions need some improving. A single lha file to extract to hard disk with all files in it would have been better than this messy method.

Anyway, once installed, I then ran the game - it prompts to see the Introduction or Start Quest:

Of course I wanted to get straight into the game, so I start the Quest and we are into Part 1:

The graphics are colourful and work well on an Amiga 600.  The screen update is a bit jerky - it does recommend an 68030 to run this game - my Amiga 600 has a 68030, but it runs at 25Mhz rather than the usual 40-50Mhz on a big box Amiga or Amiga 1200 with a 68030 accelerator.

You control the game with a joystick, and press fire when next to a person to chat to them, bringing up a dialog box revealing more of the quest:

Exploring the map you can enter houses by pressing fire when positioned near the door, which then switches to an internal view of the house:

The exit path is less clear, basically pressing fire on the grey bit that looks like where a door should be - I think a door should be there to make it more obvious where the exit is.

Even as you enplane the map you find enemies to kill, prior to entering the crypt referred to by several people you chat to as the start. Press fire to shoot the enemies - i found that often the enemy would sit on top of my position draining my health - you need to shoot them before they get that close:

Clearly someone spent a bit of time making this game look nice:

In the pub I talked to Galek:

Apparently all is not well in my home village, and I need to find his daughter who will explain what happened and why so many people have left. I eventually found his daughter:

Dunia gives a long dialogue explaining what happened, that the statue at this location has been stolen, the crypt is not safe and I need to find and bring back the statue:

So logically I head off to the crypt - here is the entrance:

Inside the crypt the passages are narrow and full of enemies to be killed and secret rooms:

Exploring the crypt:

I made a YouTube video showing the initial part of the game so you can see what to expect:

At the end of the video (for those unable to view it) I got stuck in a dead end in the crypt and had to kill myself (hit escape) to start again...I did this several times and couldn't work out how to get past it...I guess I have to keep trying!

There is a good game here but also some issues when I tried it out - the installation process is not good, the edges of the map are often closer than you think - some parts of the map that look like they should continue on (especially inside houses) hit an invisible wall you can't go past, and the shooting of enemies once they reach your position is almost impossible.

You can continue your quest from where you left off, although it is not clear how to "save" it. I guess it is automatic.

The music is a highlight - very well done. The graphics are also acceptable for an ECS Amiga game - someone spent some time making these.

It is good to see new games to play on Classic Amiga in 2014!

Saturday, 23 August 2014

AmigaOS4.1 Classic on WinUAE Part 3

Having completed all the AmigaOS Updates 3 to 6 on my AmigaOS 4.1 Classic install on WinUAE Beta 12, I now have a system ready for the next steps in Part 3!

Next is installing the AmigaOS4.1 SDK. This can be downloaded from Hyperion's website. I then created another CD ISO using ImgBurn, containing the SDK and plenty of other software to try out. I extracted the SDK archive to the hard disk and then I was ready to start the installation:

Once the installer has started, there is not much to configure really, other than where you want the SDK installed...I picked SYS:, a directory called SDK is created automatically...

This installation takes a long time - I suggest going to eat lunch/dinner, head out for a bit because it takes over an hour.

Installation eventually completes successfully:

I then Press F12 and restart the emulation. I then extracted the Codebench software (available from here) which is a development environment for AmigaOS4.1 and hooks into the SDK we just installed. Here is the Codebench installer:

I chose to install it into Sys:utilities - a directory called Codebench is created automatically:

Final confirmation of the installation before it begins:

The installation doesn't take too long fortunately:

Install done. Another F12 and restart needed:

Once the emulation has restarted I then added Codebench to Amidock and launched it. As per below I then created a new project as a test:

When I pressed OK it asked me if I want to generate the dictionary - when I said OK it froze as below:

Tried a few times but same result everytime.

Hmm, having my X1000 helped here. I already have Codebench installed on it, so I zipped up the Codebench folder on the X1000, and created an iso with the zip folder. I then extracted it on to the AmigaOS4.1 Classic emulation.

After doing this Codebench worked properly! I opened my example Hello World with GUI I had on the X1000 in the emulation:

I then compiled the program, which according to the program took 5 seconds (see screenshot), but in reality took 5 minutes! Certainly isn't very fast:

I then ran the executable generated on the Workbench:

You can also run it from the project folder where the executable was built, and the result is below:

So Codebench does work, but the speed is pretty slow. I imagine for a complex project compilation could take a long time...

I tried a game (Ace of Hearts) but it was really slow just to load the title screen - over 5 minutes and still no screen! At the moment I would stick to simple non cpu intensive applications in the emulation...

That's as far as I plan to go with this AmigaOS4.1 Classic emulation build for the time being - I am keen to get back to my A600 build now.

However, I look forward to trying out the improvements to this AmigaOS4.1 Classic emulation in the months and years ahead.

This BETA of WinUAE with PPC support is just the start, and when performance of the PPC emulation is closer to normal PPC performance this solution will be great for all Amiga users - those who want to use AmigaOS4.1 Classic on the go on their laptop, and for those users who have a PC and can't afford to buy the X1000 to run AmigaOS 4.1 at the fastest speed possible.

For me of course, I am happy to run AmigaOS4.1 on my X1000, but this development in emulating AmigaOS4.1 on PC's is very exciting indeed!

Wednesday, 20 August 2014

AmigaOS4.1 Classic on WinUAE Part 2

In Part 2 of setting up AmigaOS4.1 Classic on WinUAE I will look at how to prep and install AmigaOS4.1 Classic on a hard disk file in WinUAE.

There is a guide I followed for the AmigaOS4.0 installation here. However there are no pictures so I have done screengrabs to show the process to hopefully make it clearer what needs to be done.

I created a WinUAE configuration with a standard A1200 Kickstart 3.1 system, 2MB Chip RAM, 4MB Fast RAM (not needed really), with the Workbench 3.1 Install floppy mounted in DF0, and the AmigaOS4.1 HDF I created in Part 1 mounted (with RDB enabled) as DH0: using the default UAE driver.

Make sure that the AmigaOS4.1 Classic configuration created in Part 1 also has RDB enabled on the hard disk created.

When the emulation is started and the Install disk has booted to Workbench 3.1 desktop, open the Install3.1 disk, browse to HDTools folder and run HDToolbox:

In HDToolbox you should see the unknown SCSI disk as below:

Click on Change Drive Type, which should show the following screen:

Click on Define New... to define a new hard disk drive type:

Click on Read Configuration, then click on the Continue option in the window that appears:

You will then get a screen like below. Ignore the incorrect sizing shown. Click on OK:

You then get a screen similar to the one below. Click on OK:

Now the drive status has changed and is shown as below:

Next, click on Partition Drive:

I removed the second partition (click on the partition on the right, then select Delete Partition).

Then drag the first partition to cover the rest of the drive. Click on Advanced Options checkbox to see the additional options as shown below:

I changed the Partition device name to DH0, the File System to Fast File System (click on Change... option to change this) and then click on OK:

Now click on Save Changes to Drive, and then click Exit.

Now close the WinUAE emulation, then relaunch WinUAE and load the AmigaOS4.1 configuration created in Part 1. Then launch the emulation. When it boots you should now see the new Drive DH0:Uninitialised icon as below:

I then select the drive, then right click on the Title bar, highlight the Icon Menu and select Format Disk to see the Format Disk screen below:

I change the Volume name to System, uncheck the Put Trashcan option, and select Quick Format - it will double check you really want to do this and then it will format - this takes a few minutes so please be patient:

When done you will see the formatted drive, ready to go:

Double click on the AmigaOS4.1 Installation icon to start the installation:

Click Next and accept the Terms and Conditions. Then ensure Amiga 4000 is the model automatically selected in the screen below and click on Next:

 Click Next on this next screen:

Next it asks where to install - it should pick DH0 automatically - click on Next:

Change the Graphics Card to Picasso IV and click on Next:

Select the resolution. It gives the option for 1920x1080 (shown below) but the Picasso IV can't do this - I suggest 1024x768 @ 60hz:

Uncheck the Load the cybppc.device option and click Next:

On the next screen below just click Next:

On the next screen below just click Next:

You are now presented a summary of your installation choices prior to the Installation of files onto the hard disk:

After clicking Next, the installation of files to the hard disk starts:

As a guide, it took 1 hour on my PC to do this installation section until I got the completed screen below - so make a coffee, watch some tv or whatever!

At this point, Click Next to finish the installation. Press F12 and hit Restart (don't use Reset - soft resets don't work properly when using ppc emulation in this WinUAE version).

When the WinUAE configuration GUI comes back up, eject the boot floppy adf from DF0 and eject the AmigaOS4.1 Classic cd image and then save the configuration. Then start the emulation to boot AmigaOS4.1 from hard disk.

As a guide, booting takes around 4 minutes. You then get the post install configuration options - fantastic! It worked!

I check the screen resolution since the Picasso IV is defaulting to 1024x768x16 bit instead of 24 bit. I changed this as below, clicked Test to make sure it worked, then Clicked on Save to make the change permanent:

Here is the AmigaOS4.1 Classic desktop running under WinUAE:

At this point, you really should close WinUAE and make a backup copy of the HDF you just created so you don't have to do that installation again.

Next I downloaded the AmigaOS4.1 Updates 3,4,5 and 6 from Hyperion's website. I then used Imgburn to create an iso containing those files, and then mounted the cd image into this WinUAE session (using F12 within the emulation, then selecting the cd image file). The cd image I created then appears on the AmigaOS4.1 desktop. I do a directory in Shell to show the contents:

Next I ran UnArc from the System:Utilities folder (and added it to the AmiDock) to extract the Update3 archive to RAM: - this also takes a while, so please be patient:

Once extracted, here is the Update3 folder:

I then kicked off the Update 3 installation:

The install takes a little while, so please be patient:

Install then completes. Make sure you uncheck Restart my Computer now and then click Finish. Press F12 and select Restart in WinUAE and relaunch the emulation:

After it boots back up we now have Update 3 installed:

We can then move on to extract and install Updates 4,5 and 6. It is required to install each in order as the updates are not cumulative.

I won't bore you showing all those installs, but they follow the same pattern as the Update 3 install I have shown. Allow plenty of time for these!

In Part 3 I will cover the next part of the build configuration. Until then, have fun with AmigaOS4.1 Classic on WinUAE!